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Evaluation board/kit and Development tool important notice

1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration,
or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of
design for finished products.

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a
consumer product. The user should use it properly and in a safe manner. Seiko Epson dose not assume any
responsibility or liability of any kind of damage and/or fire coursed by the use of it. The user should cease to
use it when any abnormal issue occurs even during proper and safe use.

3. The part used for this evaluation board/kit or development tool may be changed without any notice.

NOTICE

No part of this material may be reproduced or duplicated in any form or by any means without the written
permission of Seiko Epson. Seiko Epson reserves the right to make changes to this material without notice.
Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material
or due to its application or use in any product or circuit and, further, there is no representation that this material is
applicable to products requiring high level reliability, such as, medical products. Moreover, no license to any
intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that
anything made in accordance with this material will be free from any patent or copyright infringement of a third
party. When exporting the products or technology described in this material, you should comply with the
applicable export control laws and regulations and follow the procedures required by such laws and regulations.
You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical
information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other
military purposes.

Arm, Cortex, Keil and pVision are registered trademarks of Arm Limited (or its subsidiaries) in the US and/or
elsewhere. IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR and the logotype of IAR Systems are
trademarks or registered trademarks owned by IAR Systems AB. SEGGER and J-Link are trademarks or
registered trademarks of SEGGER Microcontroller GmbH & Co. KG. All rights reserved.

All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective
companies.

‘Reproduced with permission from Arm Limited. Copyright © Arm Limited”

OSEIKO EPSON CORPORATION 2020, All rights reserved.
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1. Overview

1. Overview

The S1C31 EEPROM emulation library includes a library to emulate an EEPROM using the flash memory
embedded in the target model. Application programs with this library linked can use the embedded flash memory
as an EEPROM by calling the library functions.

This library and sample software are included in the S1IC31xxx peripheral circuit sample software package. The
S1C31xxx peripheral circuit sample software package is available on Seiko Epson’s website.

In addition to this manual, please also refer to the "S1C31xxx Technical Manual".

1.1 Features

This library implements the emulation function allowing the S1C31 Family microcontrollers to use the embedded
flash memory as an EEPROM. It uses a flash memory area of 4K to 64K bytes as an EEPROM emulation area to
emulate a 32- to 512-byte EEPROM. The number of rewriting guarantee times of the embedded flash memory is
about 1,000 times. The emulation function allocates one flash memory sector for one EEPROM address, this
makes it possible to increase the number of rewriting times of each emulated EEPROM address to 100,000 times
or more theoretically.

RAM area

Flash control processing <
Transferred to
RAM

Flash memory area
Application program area

Function call

Physical erasing
and writing of
flash memory

EEPROM emulation
library

A

EEPROM emulation area \

Sector
management

A\ 4

>+

Figure 1.1.1 EEPROM emulation library features
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1. Overview

1.2 Working Environment

The following is required when writing and debugging the sample software.

Evaluation Board
- S5U1C31xxxTx evaluation board with S1C31 series.
Debug Probes *1*2
- IAR Systems I-jet or SEGGER J-Link
Integrated Development Environment
- IAR Embedded Workbench for ARM® (IAR EWARM) or MDK-ARM® (uVision)
S1C31SetupTool package
- Includes Flash loader and Configuration files (.svd etc).

S1C31xxx Peripheral circuit sample software package

*1: Debug probes are not required for library function calls from the sample software.
*2: 1-jet is available only with IAR EWARM. J-Link is available for both IAR EWARM and MDK-ARM.

For details on the above, refer to the attached manual.

1.3 Precautions for Usage

The S1C31 EEPROM emulation library and sample software are for reference only. Our company will not take
any responsibility for any problems caused by this library. Please thoroughly verify the operation when using this
library for your product.

This manual is common to the EEPROM emulation library provided for each model of the S1C31 series. About
the specifications (RAM usage, etc.) that differ depending on the model, refer to the readme included in the
S1C31xxx peripheral circuit sample software package.

Seiko Epson Corporation S1C31 Family EEPROM
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2. Library configuration

2. Library configuration

2.1 Folder Configuration

The configuration of the S1C31 EEPROM emulation library, sample software, and related programs included in
the S1C31xxx peripheral circuit sample software package is as follows.

S1C31xxxSamplePKG_very_yy.zip
[S1C31xxxSamplePKG_very_yy]
|- [Licenses]
|- [Drivers] : Drivers

|- [board] : Evaluation board related driver
|- [CMSIS] : CMSIS driver
| |- [Device]
| | |- [S1C31xxx]
| | |- [Include]
| | | |-S1C31xxx.h : CMSIS peripheral circuit access layer header file
(. [ L
| | |- [Source]
(. |- [ARM]
(. - IAR]
| | [ |- startup_S1C31xxx.s : CMSIS sartup program
| | |- system_S1C31xxx.c : CMSIS peripheral circuit access layer header program
| |- [Driver]
| | |- [Include]
| | | |- Driver_Common.h : Common driver definition
| | | |- Driver_EEPROM.h : CMSIS EEPROM emulation library driver definition
[ I N AR
| | |- [Source]
| | |- Driver_EEPROM.c : CMSIS EEPROM emulation library driver
| [|-[SvD]
|- [sePeripheralLibrary] : Peripheral circuit library
[Middlewares] : Middlewares

|- [seEepromLibrary] : EEPROM emulation library

| |- [Device]
| |- [S1C31xxx]
| |- seEepromLibraryS1C31xxx.a : Library for AR EAWRM
| |- seEepromLibraryS1C31xxx.lib : Library for MDK-ARM
|- [Include]
| |- DataFlashCommand.h : EEPROM emulation library driver definition
| |- DataFlashConfig.h : Setting header file
|- eepromLibraryForS1c31xxx_readme_e.txt : readme
|- eepromLibraryForS1c31xxx_readme_j.txt

[Projects] : Sample softwares
- [Applications] : Various application software
|- [EEPROM] : Sample software for EEPROM emulation library
| |- [ARM] : Project for MDK-ARM
| |- [IAR] : Project for IAR EWARM
| |- main.c
|- ...

I
README_e.txt

README_j.txt

Figure 2.1.1 S1C31xxx Sample software package configuration
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2. Library configuration

2.2 Library function

The functions provided by this library are defined in Drivers\CMSIS\Driver\Include\Driver_EEPROM.h. The
functions provided by this library are as follows.

Table 2.2.1 Functions provided by the S1C31 EEPROM emulation
libraryFunction name

int32_t ProgramData (uint32_t addr, unsigned char *data, uint32_t

Functional overview

Write internal flash memory

cnt)

int32_t ReadData (uint32_t addr, unsigned char *data, int32_t cnt) Read internal flash memory
ARM_DRIVER_VERSION GetVersion (void) Get this library version

ARM_FLASH_INFO * Getlnfo (void) Get information on built-in flash memory
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3. How to Use Library

3. How to Use Library

Describes how to use the S1C31 EEPROM emulation library and sample software.
3.1 Settings for Using Library in Application Program

This section describes how to use this library on the application program. For how to incorporate the library into
the project of an application program, refer to “Appendix X. How to Incorporate Library into Project.”

1. Declaration of Header File

Include “Driver EEPROM.h” in the source file that uses this library.

#include <stdio.h>
#include <string.h>
#include "Driver_EEPROM.h"

2. Setting EEPROM size and number of write retries
Set the following values in "Driver_ EEPROM.h".

#define CONFIG_EEPROM_SIZE_MAX (512)
#define CONFIG_RETRY_COUNT (4)

® CONFIG_EEPROM_SIZE_MAX
Sets the size of the EEPROM to emulate. Please refer to the readme for the size that can be set by the user.

® CONFIG_RETRY_COUNT

Sets the number of write retries when a writing has failed. Increasing the number of write retries causes the
processing time of the writing routine to increase and performance to decrease. So it should only be set to several
times.

3. Add function

Add the functions provided by the library to the source file that uses this library. About the function specifications,
refer to "Chapter 4 Library Specifications".

extern  ARM DRIVER FLASH Driver Eeprom;

int main(void) {
unsigned char compbuf[CONFIG_EEPROM_SIZE_MAX];
ARM_FLASH_INFO *Info = Driver_Eeprom.Getinfo();
Driver_Eeprom.GetVersion(); / Write EEPROM

if (Driver_Eeprom.ProgramData(0, updateLineBit, CONFIG_EEPROM_SIZE_MAX)==ARM_DRIVER_OK)
{
printf("Program: OK\n");
Driver_Eeprom.ReadData(0, compbuf, CONFIG_EEPROM_SIZE_MAX);
if (memcmp(updateLineBit, compbuf, CONFIG_EEPRONNSIZE_MAX) ==0) {
printf("Verify: OK\n"); Read EEPROM

}else {
printf("Verify: NG\n");

}
}else {

S1C31 Family EEPROM Seiko Epson Corporation 5
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3. How to Use Library

printf("Program: NG\n");

3.2 Internal RAM and Flash Memory Usage

This library uses an internal RAM area and a flash memory area. About the RAM usage of the EEPROM
emulation library of each model, refer to the readme included in the S1C31xxx peripheral circuit sample software
package.

3.3 Write Time

The write time using this library depends on the EEPROM size configured, number of flash memory rewriting
times, the clock source to be used, and other conditions.

For reference, the following shows a write time example when data is written to the same EEPROM address
100,000 times using the EEPROM emulation library of SIC31W74:

Typ. value 4.6 ms
Max.value 27.4ms

Check the actual writing time with the application program that uses this library.

3.4 Precautions on Use of Library
When using this library, be sure to note the following points:

The S1C31D01/ S1C31D5x / S1IC31WT74 uses ch.0 of the 16-bit timer (T16). Therefore, the contents of the
register of 16-bit timer ch.0 are changed. Please note when using this library with an application program
that uses a 16-bit timer.

In this library, the system clock is changed to the high-speed clock (OSC3 or IOSC). Therefore, please note
that the contents of the control register of the clock generator (CLG) will be changed.

The EEPROM emulation area in the flash memory must be erased before this library can be used and when
the EEPROM area location and/or size are changed.

The EEPROM emulation area occupies a flash memory space of <CONFIG_EEPROM_SIZE_MAX *
DATAFLASH_SECTOR_SIZE > bytes. CONFIG_EEPROM_SIZE_MAX should be set so that the
EEPROM emulation area will not exceed the flash memory capacity.

When using this library, connect a capacitor to the Vpp pin as shown in the basic external connection
diagram in the “S1C31xxx Technical Manual”, and disconnect the connection between the Vpp pin and
other pin.

Be aware of the number of flash memory rewriting guarantee times when using this library. For the flash
memory specifications, refer to the “S1C17(xxx) Technical Manual”.

While executing the write function, supply the Voo operating voltage for Flash programing (When Ver is
generated internally) specified in the data sheet of each model. If the voltage falls outside the range, the
written value is not guaranteed.

6 Seiko Epson Corporation S1C31 Family EEPROM
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3. How to Use Library

3.5 Sample Program

1. Sample program specification

The sample software uses the SIC31 EEPROM emulation library to write the increment data from address 0 to
(CONFIG_EEPROM_SIZE_MAX -1).

2. Preparation

About details on how to execute this sample software project in an integrated development environment, refer to
the "S1C31xxx Peripheral Circuit Sample Software Manual".

3. Operation overview

(1) Get information on the built-in flash memory. (optional)

(2) Get the version of the S1IC31 EEPROM emulation library. (optional)
(3) Write updateLineBit [] (512 bytes) of update data to EEPROM.

(4) Read 512 bytes of data from the EEPROM.

(5) Compares cmpbuf [] of the read data with updateLineBit [] of the update data and displays the result.
(\Verify)

S1C31 Family EEPROM Seiko Epson Corporation 7
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4. Library Specifications

4.

Library Specifications

4.1 EEPROM Read/Write Function Details

Details of the functions provided by the S1C31 EEPROM emulation library are described below.

Function name

int32_t ProgramData (uint32_t addr, unsigned char *data, uint32_t cnt)

Arguments uint32_t addr | Write address.
Scope: 0 - (CONFIG_EEPROM_SIZE_MAX - 1)
const void * data |Write data.
Indicates a pointer to the write data. The pointer must point to the RAM area.
uint32_t cnt Write data size.
Return value |int Write result. (error code)

Description

Write EEPROM.

(1) Check if the argument is within the EEPROM address.
(2) Writes the write data to the specified write address.
(3) Check if the write address is write data. (Verify)

(4) Returns the writing result.

Remarks

None.

Function name

int32_t ReadData (uint32_t addr, unsigned char *data, int32_t cnt)

Arguments uint32_t addr |Read address.
Scope: 0 - (CONFIG_EEPROM_SIZE_MAX - 1)
const void * data |Read data.
Indicates a pointer to the write data. The pointer must point to the RAM area.
uint32_t cnt Read data size.
Return value |uint32_t ARM_DRIVER_OK (0)

Description Read EEPROM.
(1) Check if the argument is within the EEPROM address.
(2) Reads to the specified read address.
(3) Returns the reading result.

Remarks None.

Function name

ARM_DRIVER_VERSION GetVersion (void)

Return value

ARM_DRIVER_VERSION This library version.

Description

Get this library version.

Remarks

None.

Function name

ARM_FLASH_INFO * Getlnfo (void)

Return value

ARM_FLASH_INFO * Built-in flash memory information.

Description The following is acquired as the information of the built-in flash memory.
Number of sectors
Size of EEPROM
Remarks None.
8 Seiko Epson Corporation S1C31 Family EEPROM
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4. Library Specifications

4.2 Error Code Definitions

The error code used in the return value of each function is as follows.

Table 4.2.1 Error Codes

Definition Name Value Description
ARM_DRIVER_OK 0 Successfully completed.
ARM_DRIVER_ERROR_TIMEOUT -3 | Timeout/ Verify error
ARM_DRIVER_ERROR_UNSUPPORTED -4 Unsupported operation
ARM_DRIVER_ERROR_PARAMETER -5 | Argument error

These definitions are defined in Drivers\CMSIS\Driver\Include\Driver_Common.h.

S1C31 Family EEPROM Seiko Epson Corporation 9
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Appendix

Appendix

A. How to Incorporate Library into Project (IAR EAWRM)

The following describes how to incorporate the SIC31 EEPROM emulation library into the project of application
program created by IAR EWARM. About IAR EWARM, please refer to the attached manual.

1. AddLibrary
(1) Select [Project]> [Options] from the IAR EWARM menu.

(2) Select [Linker] from the [Category] list in the displayed dialog.

(3) From the [Library] tab, add this library included in the S1C31xxx peripheral circuit sample software
package to "Additional libraries".

Middlewares\seEepromLibrary\Device\S1C31xxx\seEepromLibraryS1C31xxx.a

< EEPROM - IAR Embedded Workbench IDE - Arm Options for node "EEPROM™
File Edit WView Project J-link Tools Window Help
MO R = X0 DC - £ Q)
Waorkspace v o x Cetiamyy Factory Setings
DiebugFlash " General Opm?ns ~
Static Analysis
Files & . Runtime Checking s I = T pr— e
1 C/C++ Compi #define iagnostics ecksum ncodings ra Options
M board S I_Optlons.... I Assemh;mpl o Con(3) Input Optimizations ~ Advanced Output  List
M CMSIS
a sePeripheralLibrary iz grxr;(;uu;;arter [ Automatic runtime library selection
Compil
Driver EEPROM.c Q :: P\IdeAH Build Actions Additional libraries: (one per ling)
{— E Driver_EEPROM.h o (2) P $PROJ_DIRSY. ¥..%, ¥Middlewares¥seEepromLibrary¥Device¥S 10311 E
main.c Clean Debugger
= Output C-STAT Static Analysis ¥ Simulator
CADL
Stop Build CMSIS DAP .
GDB Server [ Override default program entry
Add > I-jet Entry symbol __lar_program_start
Remove J-Linky3-Trace Mo entry symbol
T1 stellaris
Rename...
Mu-Link
Versien Control System > PE micro
ST-LINK
Open Containing Folder.. Third-Party Driver
File Properties... e
Set as Active
Cancel
Figure A.1 Add library
(4) Select [Project]> [Add]> [Add File] from the IAR EWARM menu.
(5) Add the following driver and driver definition.
Drivers\CMSIS\Driver\Source\Driver EEPROM.c
Drivers\CMSIS\Driver\Include\Driver_EEPROM.h
10 Seiko Epson Corporation S1C31 Family EEPROM
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Appendix

< EEPROM - IAR Embedded Workbench IDE - Arm

File Edit View Project J-Link Tools Window Help

0 e =% R D C 1< Q> K= < > |
Waorkspace » 0 X
D ebugFlash i
Files E+ I
[{€3] EEPROM - DebuqgFlash Ooti
B board ptions
H CMSIS Make
M sePeripherallibrary Eom
Driver_EEPROM.c i
F— B Driver_EEPROM.h Reue
main.c Clean
B Output ) i
C-5TAT Static Analysis >
Stop Build
>
Remove Add Group...
Rename...
Wersion Control System >

Open Containing Folder..
File Properties...

Set as Active

Figure A.2 Add CMSIS driver

2. Include Path Settings
(1) Select [Project] > [Options] from the IAR EWARM menu.
(2) Select [C/C ++ Compiler] from the [Category] list in the displayed dialog.

(3) From the [Preprocessor] tab, add the following include path of the driver definition included in the
S1C31xxx peripheral circuit sample software package to the "Additional include directories".

+  Drivers\CMSIS\Driveninclude
+  Middlewares\seEepromL.ibrary\Include

< EEPROM - IAR Embedded Workbench IDE - Arm

Options for nede "EEPROM"
File Edit View Project J-link Tools Window Help

D@ = L0 OC <. Q
‘Workspace * o x Category Factony Settings
DebugFlash 7 General Options ~ [T Mulki-file Compilation
Static Analysis Discard Unused Publics
Files @ . Runtime Checkin 5 5
Z€3] EEPROM - DebugFlash b @ m MISRA-(:1998 Encedings Extra Options
B board I_Ipllons... Assembler Language 1 Language 2 Code Optimizations Output
B CMSEIS Make Output Converter List (3) Diagnostics MISRA-C:2004
se.Perlphera\lerary Farls Custom Buld
Drriver_EEFROM.C Build Actions [Tignore standard include directories
}— [ Driver_EEPROM.h Rebuild Al i '
. Linker Additional include directories: (one per line)
] main.c Clean Debugger
B Output WEEROJ DIREE 2.2 2 3Dnvers WIS Drvertincludes - E
C-STAT Static Analysis : Simulator $PROJ_DIRS¥..%.¥.% . ¥Drivers¥sePeripheralLibrary¥
CADI $PROJ_DIRS¥. £ ¥ ¥ ¥Drivers¥board¥55LN 03 oo 1¥
Stop Build CMSIS DAP $PROJ DIR$¥. L. L ¥ ¥Middlewares¥seEepromLibrary¥lnclude
v
Add 5 GI?B Server
Tjet Preinclude file:
Remove JHink/1-Trace
EEne TI Stellaris
Nu-Link Defined symbols: (one per ling)
Version Control System > PE micro S1CTTuxx [ Preprocessor output to file
.. STLINK Presenve comments
Open Containing Folder.. Third-Party Driver Generate #line directives
File Properties... r waen cor
Set as Active
Cancel
Figure A.3 Set include path
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Appendix

3. Linker Script Settings
(1) Edit the linker script file (.icf) included in the project.

(2) Refer to the linker script file (S1C31xxx_flash.icf) of the sample software included in the S1C31xxx
peripheral circuit sample software package, and add the following sections.

initialize by copy { readwrite }; Creating a flash common text section

initialize manually with packing = none { section .flash_common_text};

/linitialize by copy with packing = none { section _ DLIB_PERTHREAD }; // Required in a multi-threaded
application

do not initialize { section .noinit };

place at address mem:__ICFEDIT _intvec_start __ { readonly section .intvec };

. . Specifying the co ource section of the ROM area
place in ROM_region  { readonly }; s;A/ pecifying py source secti
C

place in RAM region  { readwrite, block C K, block HEA Specifying the copy destination section of the
place in ROM_region  { section .flash_common_text_init}s P g Py

. q q RAM area
place in RAM _region  { section .flash_common_text ¥,

Specify the start address of the internal flash
memory used as the EEPROM emulation area

/"ROMZ2":place in ROM2_region { section EEPR }
place at address mem: 0x20000 { readonly section EEPROML1 };

When the above is added, the code of this library is placed in the RAM area in this library. Also, specify the
internal flash memory to be used as the EEPROM emulation area. Specify the start address in the unit
described in the readme.

(3) Select [Project] > [Options] from the IAR EWARM menu.
(4) Select [Linker] from the [Category] list in the displayed dialog.
(5) From the [Config] tab, check "Default Override" and specify the edited linker script file.

¢ EEPROM - IAR Embedded Workbench IDE - Arm

Options for node "EEPROM"

File Edit View Project J-link Tools Window Help

+ 1) ) \ i e Fa]
DO R = XEGDC - £ L3
Workspace o x Category: Factory Seflings
DebugFlash ~ General Options -
X Static Analysis
Files & . ‘

Runtime Checking
Fdefine Diagnostics Checksum Encodings Extra Options

[EE)) FEPROM - DebugFlash I I C/C 4+ Compiler
-_board Options.. Assembler ( Library  Input Optimizations ~ Advanced Output List
B CM3IE Make Output Converter Linker configuration file

W sePeripheralLibrary custom Buid
Driver_EEPROM.c wstom U B4 Override default

wn

Compile

— B Driver_EEPROMh Rebuild Al |$PROJ_D\R$¥con‘ig¥S1 C31D5x_flash.icf | D
main.c Clean (4) I
B Output Bebugger Edit
C-STAT Static Analysis > Simulator
CADIL
Stop Build CMSIS DAP Configuration file symbol definitions: (one per ling)
Add 3 GDE Server
Ijet
Remove Iink/I-Trace
Rename... TI Stellaris
Mu-Link
Version Control System > PE micro
Open Containing Folder... STAINK
Third-Party Driver

File Properties...

Set as Active

Cancel
Figure A.4 Set linker script file
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Appendix

B. How to Incorporate Library into Project (MDK-ARM)

The following describes how to incorporate the SIC31 EEPROM emulation library into the project of application
program created by MDK-ARM (uVision). About MDK-ARM, please refer to the attached manual.

1. AddLibrary
(1) Right-click the target source folder in the uVision [Project] window and select [Add Existing Files to Group
xxx’...].

(2) From the displayed dialog, add this library and driver included in the S1C31xxx peripheral circuit sample
software package below.

Middlewares\seEepromL.ibrary\Device\S1C31xxx\seEepromLibraryS1C31xxx.lib
Drivers\CMSIS\Driver\Source\Driver_ EEPROM.c

File Edit View Project Flash Debug Peripherals Tools
& A o
[EARA7 > 2 ¥ DebugFlash v X|d
Project L x|

% Project: eeprom

-] %4 DebugFlash

®

2 ,& Options for Group 'SRC'.., Alt+F7
] -
—] Add New Item to Group 'SRC'...
—»] I Add Existing Files to Group 'SRC'...
—] Remove Group ‘SRC' and its Files

# 1 boa [ Rebuild all target files

% g seP| [ Build Target F7
™M

Manage Project Items...

v | Show Include File Dependencies

—

« | &
Eproject |G {3 Functions | 0, Templat

Figure B.1 Add library

2. Include Path Settings

(1) Select [Project]> [Options for Target ‘xxx’...] from the uVision menu.

(2) Browse to the folder from [C / C ++]> ‘Include Paths’ in the displayed dialog.

(3) From [New (Insert)], add the following include path of the driver definition included in the S1C31xxx
peripheral circuit sample software package.

Drivers\CMSIS\Driver\Include
Middlewares\seEepromLibrary\Include
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Appendix

(V. (1) Options for Target 'DebugFlash’ @ X
File Edit Vie Project | Flash Deb Peripherals
' : e ue fpher Device | Tareet | Output | Listing | User Asm | Linker | Debue | Utilities |
_j » " New pVision Project...
e New Multi-Project Workspace... Preprocessor Symbols
Project Open Project... Define ‘S‘ICEI XXX
Close Project
= ‘1% Project: eepl L Undefine ‘
=N Export
i DebugFl PO Language / Code Generation
=S i‘c Manage I~ Execute-only Code [~ Stict ANSIC Wamings m
5
Q) Select Device for Target Optimization: |Level 0(00) ~ I™ Enum Container always int I~
B Remove Item I~ Optimize for Time ™ Plain Charis Signed [~ No Auto Includes
R I X Options for Target ‘DebugFlash’... I~ Split Load and Store Multiple [ Read-Only Position Independent v C99 Mode
Bl [~ One ELF Section per Function [” Read-Write Position Independent ™ GNU extensions
Clean Targets
b
i °:’ (] Build Target include [ ¥ ¥ ¥ ¥Divers¥ooard¥55U1CT oo T1. ¥ ¥ ¥ ¥Drwers¥CMISIS¥Device¥S 13 aa¥include. D
5O sePef . ) s
0 oMs L‘J Rebuild all target files Misc [
& Batch Build Controls
&ﬁ Batch Setup... Compiler ~093 < -cpu Cortex-M0+-D__EVALig OD -apcsnnlerwoﬁc 4.4 ~
control /Drivers/board/S5UTC31xxx T1- .. ../Drivers/CMSIS/Device/S1C3 Txxx e -
Translate string v
Stop build
I‘ QK I I Cancel I Defaults | Help
Folder Setup ? X

M)
)

Setup Compier Include Paths @ [+ +

¥ ¥ ¥ ¥Drivers¥board¥S5U1C31xxxT1

¥.¥ ¥ ¥Drivers¥CMSIS¥Device¥S1C3 xx¥include
¥ ¥ ¥ ¥Drivers¥sePeripheralLibrary

¥ ¥.¥ ¥Drivers¥sePeripheralLibrany¥Device¥S1C3 xxx
¥ ¥ ¥ ¥Drivers¥CMSIS¥Driver¥include

¥ ¥.¥ ¥Middewares¥se EepromUbrary¥Include

0K |
Figure B.2 Set include path

Cancel

Linker Script Settings

Edit the linker script file (.sct) included in the project.

Refer to the linker script file (S1C31xxx_flash.icf) of the sample software included in the S1C31xxx
peripheral circuit sample software package, and add the following sections.

LR_IROM1 0x00000000 000020000 {
RW_IRAM2 +0{ :;RW deta___——
*(.flash_common_text)

¥
ARM_LIB_HEAP 0x00151800 EMPTY 0x400 ; Heap region growing up

{}
ARM_LIB_STACK 0x00152000 EMPTY -0x400

} {3 Specify the start address of the internal flash
memory used as the EEPROM emulation area

LR_IROM2 0x00020000 0x00010000 {
ER_IROM2 0x00020000 0x00010000 {
*(.eeprom)

; load region size_region

Creating a flash_common_text section in RAM area

; Stack region growing down

; load region size_region
; load address = execution address

When the above is added, the code of this library is placed in the RAM area in this library. Also, specify the
internal flash memory to be used as the EEPROM emulation area. Specify the start address in the unit
described in the readme.
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Appendix

(3) Select [Project]> [Options for Target ‘xxx’...] from the uVision menu.

(4) Specify the linker script file edited from [Linker]> ‘Scatter File’ in the displayed dialog.

ud )

=S
EAN: X
Project

= ‘i Project: eepi
= 5% DebugFl
=5 SRC
114
-

File Edit vlewFIash Debug Peripherals

New pVision Project...

New Multi-Project Workspace...
Open Project...

Close Project

Export
Manage
Select Device for Target ...

Remove Item

i -
RS

Options for Target 'DebugFlash’...

e
+d boar

#-{ sePe

@ cms

)

CECEE

Clean Targets

Build Target

Rebuild all target files
Batch Build

Batch Setup...
Translate

Stop build

Options for Target ‘DebugFlash’ (4) x
Device | Target | Output | Listing | User | G/C++ | Asm Debue | Utilities |
[ Use Memory Layout from Target Dialog X/0 Base:
[ Make RW Sections Position Independent R/O Base:
[~ Make RO Sections Posttion Independent R/W Base ﬁ
™ Dont Search Standard Libraries
[¥ Report ‘might fail' Conditions as Emors disable Wamings: [
Scagler ¥eeprom_flash.sct ﬂ D Edit...
ile
Misc
controls
Linker |-cpu Cortex-M0+ "o ~
control  |-strict —scatter * ¥eeprom_flash sct”
string v
I 0K l I Cancel l [ Defaults l

Figure B.3 Set linker script file
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