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Evaluation board/kit and Development tool important notice 

1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration, 

or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of 

design for finished products. 

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a 

consumer product. The user should use it properly and in a safe manner. Seiko Epson dose not assume any 

responsibility or liability of any kind of damage and/or fire coursed by the use of it. The user should cease to 

use it when any abnormal issue occurs even during proper and safe use. 

3. The part used for this evaluation board/kit or development tool may be changed without any notice. 

 

 

NOTICE 

No part of this material may be reproduced or duplicated in any form or by any means without the written 

permission of Seiko Epson.  Seiko Epson reserves the right to make changes to this material without notice.  

Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material 

or due to its application or use in any product or circuit and, further, there is no representation that this material is 

applicable to products requiring high level reliability, such as, medical products.  Moreover, no license to any 

intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that 

anything made in accordance with this material will be free from any patent or copyright infringement of a third 

party. When exporting the products or technology described in this material, you should comply with the 

applicable export control laws and regulations and follow the procedures required by such laws and regulations. 

You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical 

information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other 

military purposes. 

 

Arm, Cortex, Keil and µVision are registered trademarks of Arm Limited (or its subsidiaries) in the US and/or 

elsewhere. IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR and the logotype of IAR Systems are 

trademarks or registered trademarks owned by IAR Systems AB. SEGGER and J-Link are trademarks or 

registered trademarks of SEGGER Microcontroller GmbH & Co. KG. All rights reserved. 

All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective 

companies. 

“Reproduced with permission from Arm Limited. Copyright © Arm Limited” 

©SEIKO EPSON CORPORATION 2021, All rights reserved. 

 



 

S1C31 Family Seiko Epson Corporation i 
PA File Creation Tool Manual 
(Rev.3.0) 

Table of Contents 

1. Overview ..................................................................................................................... 1 

1.1 Working Environment ................................................................................................................ 1 

2. Installation .................................................................................................................. 2 

2.1 Installation instructions ............................................................................................................. 2 

2.2 Folder structure .......................................................................................................................... 4 

3. Registering Tool ......................................................................................................... 5 

3.1 Using IAR EWARM...................................................................................................................... 5 

3.2 Using MDK-ARM ......................................................................................................................... 7 

4. Creating PA File .......................................................................................................... 8 

4.1 Using IAR EWARM...................................................................................................................... 8 

4.2 Using MDK-ARM ......................................................................................................................... 9 

Revision History ............................................................................................................. 10 

 





1. Overview 
 

S1C31 Family Seiko Epson Corporation 1 
PA File Creation Tool Manual 
(Rev.3.0) 

1. Overview 

This tool creates a PA file (Seiko Epson’s data for submission) from an ELF file (ROM data) by development 

environment. If using the service to load user programs to the internal flash memory in S1C31 Family at Seiko 

Epson’s factory, a PA file must be created and submitted to Seiko Epson. 

 

1.1 Working Environment 

To use this package, the following conditions are necessary: 

-  PC 

     Windows 10 

-  ARM® development environment 

     IAR Embedded Workbench for ARM® (IAR EWARM) or MDK-ARM® (uVision) 

-  S1C31 Setup Tool Package 

     Includes Flash loader and PA file creation tools. 
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2. Installation 

2.1 Installation instructions 

This section describes how to install the S1C31SetupTool package, which includes the S1C31 Family PA file 

creation tool. 

 

(1) Download S1C31SetupTool.zip from our microcontroller website and unzip it to any folder. 

(2) Execute “s1c31ToolchainSetup.exe” from the extracted folder. 

(3) After the installer starts, follow the installer's instructions to perform the installation. 

1. Check the installation contents. 

2. Check the terms of the license agreement. 

3. Select C31_PA. 

4. Select installation folder and execute installation. 

5. Exit the installer. 
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2.2 Folder structure 

The structure of the installation folder is as follows: 

C:\EPSON (default) 

\C31_PA 

   uninstall.exe    Uninstaller 

   license.txt    License file for this package 

   \TOOL 

      ptd.exe    Motorola-S2-format file conversion tool 

      winmdc17.exe   PA file creation tool 

   \IAR 

      c31_setup.bat          Batch file for setting up this tool for IAR EWARM 

         S1C31xxx_create_pa.bat     Execution batch file for IAR EWARM 

         … 

   \ARM 

      c31_setup.bat          Batch file for setting up this tool for MDK-ARM 

         S1C31xxx_create_pa.bat     Execution batch file for MDK-ARM 

         … 

   \mcu_model                Folder of the model-specific files for creating PA file 

         \S1C31xxx 

         … 
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3. Registering Tool 

By registering this tool to the IDE (IAR EWARM or MDK-ARM) as external tool, you can create a PA file in the 

IDE. Follow the procedure below to register this tool. 

3.1 Using IAR EWARM 

(1) Launch the IAR EWARM 

    Launch the IAR EWARM form the start menu. 

(2) Register the PA file creation tool 

  Follow the steps below to register the PA file creation tool as an external tool in the IAR EWARM. 

1. Select the [Tools] > [Configure Tools…] in IDE menu to open the [Configure Tools] dialog. 

 

 
Figure 3.1.1 Display of [Configure Tools] dialog 

 

2. Click the [New] button. 

 

 
Figure 3.1.2 Display of [New] 
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3. Ten enter the ‘Create S1C31xxx PA File’ in the text box at the [Menu Text:]. 

Note) xxx : Indicates the target model name. 

4. Click the [Browse…] button at the [Command:], and then select the S1C31xxx_create_pa.bat in 

C:\EPSON\C31_PA\IAR(default installation folder). 

5. Enter the ‘"$EXE_DIR$" "$PROJ_FNAME$" "$TARGET_FNAME$" "$EW_DIR$"’ in the text box 

at the [Argument:]. 

6. Enter the ‘$EXE_DIR$’ in the text box at the [Initial Directory:]. 

7. Enable the [Redirect to Output Window:] checkboxes. 

8. Disable the [Prompt for Command Line:] checkboxes. 

9. Select the [When not debugging] in the [Tool Available:] drop dawn list. 

10. Click the [OK] button to complete the tool registration.   

 

 
Figure 3.1.3 Setting of tool 
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3.2 Using MDK-ARM 

(1) Launch the uVision (MDK-ARM) 

    Launch uVision which is IDE included with MDK-ARM. 

(2) Register the PA file creation tool 

  Follow the steps below to register the PA file creation tool as an external tool in the IDE. 

1. Select the [Tools] > [Customize Tools Menu…] in IDE menu to open the [Customize Tools Menu] 

dialog. 

 

 
Figure 3.2.1 Display of [Customize Tools Menu] dialog 

 

2. Double-click the blank line in [Menu Content:], and then enter the ‘Create S1C31xxx PA File’. 

3. Click the […] button at the [Command:], and then select the S1C31xxx_create_pa.bat in 

“C:\EPSON\C31_PA\ARM”(default installation folder). 

4. Enter the ‘$L’ in the text box at the [Initial Folder:]. 

5. Enter the ‘"$L" "@L" "%L" "$K"’ in the text box at the [Arguments:]. 

6. Disable the checkboxes, [Prompt for Arguments], [Run Minimize] and [Run Independent]. 

7. Click the [OK] button to complete the tool registration. 

 

 
Figure 3.2.1 Setting of [Customize Tools Menu] 
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4. Creating PA File 

If you want to use the service to load the user programs to the internal flash memory of the S1C31 Family at the 

Seiko Epson’s factory, you need to create a PA file and submit it to Seiko Epson. 

Follow the procedure below to create a PA file.  

4.1 Using IAR EWARM 

This section uses the S1C31xxx peripheral circuit sample software provided by Seiko Epson as an example.  

(1) Open the Workspace 

Launch the IAR EWARM, and then select the [File] > [Open] > [Workspace...] in the IDE menu to open the 

Examples\WORKSPACE\IAR\Examples.eww. 

(2) Create the ELF file(*.out) 

Set the desired project as active and select the build configuration with “Flash” (ex. DebugFlash or Release 

Flash). Then select the [Project] > [Make] in IDE menu to build the active project. After the build is 

completed, an ELF file (*.out) is created in the “$PROJ_DIR\{build configuration}\Exe” folder. 

(3) Create the PA file 

Select the [Tools] > [Create S1C31xxx PA File] in IDE menu to create the PA file. 

 

 

Figure 4.1.1 Creating a PA file 

 

When a PA file generation succeeds, the following message is output to the [Tool output] window displayed 

at the bottom of IDE. 

* 

*  OK     PA file is created. 

* 

************************************************************************ 

The PA file (*.PA) is created in the folder where the ELF file(.out) exists. 
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4.2 Using MDK-ARM 

This section uses the S1C31xxx peripheral circuit sample software provided by Seiko Epson as an example.  

(1) Open the Workspace 

Launch the uVsion(MDK-ARM), and then select the [Project] > [Open Project…] in the IDE menu to open 

the Examples\WORKSPACE\ARM\Examples.uvmpw. 

(2) Create the ELF file(*.axf) 

Set the desired project as active and select the build configuration with “Flash” (ex. DebugFlash). Then 

select the [Project] > [Build ‘xxx (yyy)’] in IDE menu to build the active project. After the build is 

completed, an ELF file (*.axf) is created in the $PROJ_DIR\obj\{build configuration} folder. 

(3) Create the PA file 

Select [Tool] > [Create C31 PA File] in uVision menu to create the PA file. 

 

Figure 4.2.1 Creating a PA file 

 

When a PA file generation succeeds, the following message is output to the [Build Output] window 

displayed at the bottom of uVision. 

* 

*  OK     PA file is created. 

* 

************************************************************************ 

The PA file (*.PA) is created in the folder where the ELF file(.axf) exists. 
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 International Sales Operations 

 

 

America 
Epson America, Inc. 

 
Headquarter: 

3131 Katella Ave., Los Alamitos, CA 90720, USA 

Phone: +1-562-290-4677 

 

San Jose Office: 

214 Devcon Drive 

San Jose, CA 95112 USA 

Phone: +1-800-228-3964 or +1-408-922-0200 

 

 

Europe 
Epson Europe Electronics GmbH 
Riesstrasse 15, 80992 Munich, 

Germany  

Phone: +49-89-14005-0 FAX: +49-89-14005-110 

 

 

 

Asia 
Epson (China) Co., Ltd. 
4th Floor, Tower 1 of China Central Place, 81 Jianguo Road, Chaoyang 

District, Beijing 100025 China  

Phone: +86-10-8522-1199 FAX: +86-10-8522-1120 

 

Shanghai Branch 
Room 1701 & 1704, 17 Floor, Greenland Center II,  

562 Dong An Road, Xu Hui District, Shanghai, China 

Phone: +86-21-5330-4888     FAX: +86-21-5423-4677 

 

Shenzhen Branch 
Room 804-805, 8 Floor, Tower 2, Ali Center,No.3331 

Keyuan South RD(Shenzhen bay), Nanshan District, Shenzhen 

518054, China 

Phone: +86-10-3299-0588 FAX: +86-10-3299-0560 

 

 

 

Epson Taiwan Technology & Trading Ltd. 
15F, No.100, Songren Rd, Sinyi Dist, Taipei City 110. Taiwan 

Phone: +886-2-8786-6688  

 

 

Epson Singapore Pte., Ltd. 

438B Alexandra Road,  

Block B Alexandra TechnoPark, #04-01/04, Singapore 119968 

Phone: +65-6586-5500 FAX: +65-6271-7066 

 

 

Epson Korea Co.,Ltd 
10F Posco Tower Yeoksam, Teheranro 134 Gangnam-gu,  

Seoul, 06235, Korea 

Phone: +82-2-3420-6695 

 

 

 
Seiko Epson Corp. 

Sales & Marketing Division 

 

Device Sales & Marketing Department 

29th Floor, JR Shinjuku Miraina Tower, 4-1-6 Shinjuku,  

Shinjuku-ku, Tokyo 160-8801, Japan 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Document Code: 414184100 

First Issue January 2021 


	1. Overview
	1.1 Working Environment

	2. Installation
	2.1 Installation instructions
	2.2 Folder structure

	3. Registering Tool
	3.1 Using IAR EWARM
	3.2 Using MDK-ARM

	4. Creating PA File
	4.1 Using IAR EWARM
	4.2 Using MDK-ARM

	Revision History

