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Evaluation board/kit and Development tool important notice 
1. This evaluation board/kit or development tool is designed for use with engineering evaluation, demonstration, or development purposes only. 

Do not use it for other purposes. It is not intended to meet the design requirements of finished products.  
2. This evaluation board/kit or development tool is intended for use by an electronic engineer and is not a consumer product. The user should use 

it properly and in a safe manner. Seiko Epson does not assume any responsibility or liability of any kind of damage and/or fire caused by its 
use. The user should cease to use it when any abnormal issue occurs even during proper and safe use.  

3. Parts used for this evaluation board/kit or development tool may be changed without any notice. 
 
 
NOTICE : PLEASE READ THE FOLLOWING NOTICE CAREFULLY BEFORE USING THIS DOCUMENT 
The contents of this document are subject to change without notice. 
 
1. This document may not be copied, reproduced, or used for any other purpose, in whole or in part, without the consent of the Seiko Epson 

Corporation (“Epson”). 
2. Before purchasing or using Epson products, please contact our sales representative for the latest information and always be sure to check the 

latest information published on Epson’s official web sites and other sources. 
3. Information provided in this document such as application circuits, programs, usage, etc., are for reference purposes only. Using the 

application circuits, programs, usage, etc. in the design of your equipment or systems is your own responsibility. Epson makes no guarantees 
against any infringements or damages to any third parties’ intellectual property rights or any other rights resulting from the information. This 
document does not grant you any licenses, intellectual property rights or any other rights with respect to Epson products owned by Epson or 
any third parties. 

4. Epson is committed to constantly improving quality and reliability, but semiconductor products in general are subject to malfunction and 
failure. By using Epson products, you shall be responsible for your hardware. Software and systems must be designed well enough to prevent 
death or injury as well as any property damage even if any of the malfunctions or failures might be caused by Epson products. When 
designing your products using Epson products, please be sure to check and comply with the latest information regarding Epson products (this 
document, specifications, data sheets, manuals, Epson’s web site, etc.). When using the information included above materials such as product 
data, charts, technical contents, programs, algorithms and application circuit examples, you shall evaluate your products both on a stand-alone 
basis as well as within your overall systems. You shall be solely responsible for deciding whether or not to adopt and use Epson products. 

5. Epson has prepared this document and programs provided in this document carefully to be accurate and dependable, but Epson does not 
guarantee that the information and the programs are always accurate and complete. Epson assumes no responsibility for any damages which 
you incur due to misinformation in this document and the programs. 

6. No dismantling, analysis, reverse engineering, modification, alteration, adaptation, reproduction, etc., of Epson products is allowed. 
7. Epson products have been designed, developed and manufactured to be used in general electronic applications (office equipment, 

communications equipment, measuring instruments, home electronics, etc.) and applications individually listed in this document (“General 
Purpose”). Epson products are NOT intended for any use beyond the General Purpose uses that requires particular/higher quality or reliability 
in order to refrain from causing any malfunction or failure leading to death, injury, serious property damage or severe impact on society, 
including, but not limited to those listed below. Therefore, you are advised to use Epson products only for General Purpose uses. Should you 
desire to buy and use Epson products for a particular purpose other than a General Purpose uses, Epson makes no warranty and disclaims with 
respect to Epson products, whether express or implied, including without limitation any implied warranty of merchantability or fitness for any 
particular purpose. Please be sure to contact our sales representative and obtain approval in advance. 
【Particular purpose】 

Space equipment (artificial satellites, rockets, etc.) 
Transportation vehicles and their control equipment (automobiles, aircraft, trains, ships, etc.) 
Medical equipment (other than applications individually listed in this document) / Relay equipment to be placed on ocean floor 
Power station control equipment / Disaster or crime prevention equipment / Traffic control equipment / Financial equipment 
Other applications requiring similar levels of reliability as those listed above 

8. Epson products listed in this document and our associated technologies shall not be used in any equipment or systems that laws and 
regulations in Japan or any other countries prohibit to manufacture, use or sell. Furthermore, Epson products and our associated technologies 
shall not be used for developing weapons of mass destruction, or any other military purposes or applications. If exporting Epson products or 
our associated technologies, you shall comply with the Foreign Exchange and Foreign Trade Control Act in Japan, Export Administration 
Regulations in the U.S.A. (EAR) and other export-related laws and regulations in Japan and any other countries and follow the required 
procedures as provided by the relevant laws and regulations. 

9. Epson assumes no responsibility for any damages (whether direct or indirect) caused by or in relation with your non-compliance with the 
terms and conditions in this document. 

10. Epson assumes no responsibility for any damages (whether direct or indirect) incurred by any third party that you assign, transfer, loan, etc., 
Epson products to. 

11. For more details or other concerns about this document, please contact our sales representative. 
12. Company names and product names listed in this document are trademarks or registered trademarks of their respective companies. 

Arm, Cortex, Keil and µVision are registered trademarks of Arm Limited (or its subsidiaries) in the US and/or elsewhere. IAR Systems, IAR 
Embedded Workbench, C-SPY, I-jet, IAR and the logotype of IAR Systems are trademarks or registered trademarks owned by IAR Systems 
AB. SEGGER and J-Link are trademarks or registered trademarks of SEGGER Microcontroller GmbH & Co. KG. All rights reserved. 
All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective companies. 
“Reproduced with permission from Arm Limited. Copyright © Arm Limited” 
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1. Overview 
This manual describes how to use the peripheral circuit sample software included in the S1C31xxx peripheral 
circuit sample software package. The peripheral circuit sample software is intended to show how to use the 
peripheral circuit library to control the S1C31xxx peripheral circuits. 

 

In addition to this manual, please also refer to the following. 

 S1C31xxx Technical Manual … Microcontroller details. Available from Seiko Epson website. 

 S5U1C31xxxTx Manual … Evaluation Board details. Available from Seiko Epson website. 

 Manual for debug probe and integrated development environment 

 

1.1  Operating Environment  

Before running the peripheral circuit sample software, prepare the following components: 

• Evaluation Board 

- S5U1C31xxxTx evaluation board equipped with S1C31 Family 

• Debug Probes *1 

- IAR Systems I-jet or SEGGER J-Link 

• Integrated Development Environment 

- IAR Embedded Workbench for ARM® (IAR EWARM) or MDK-ARM® (uVision) 

• S1C31 Setup Tool Package 

- Flash loader and configuration files (.svd, etc.) 

• Other Devices (option) 

*1: I-jet is available only with IAR EWARM. J-Link is available for both IAR EWARM and MDK-ARM. 
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2 Peripheral circuit sample software package configuration 

2.1 Folder configuration 

The configuration of the S1C31xxx peripheral circuit sample software package is as follows. 

 
Figure 2.1.1 Configuration of the S1C31xxx peripheral circuit sample software package 

s1c31xxxsp_very_yy.zip 
[s1c31xxxsp_very_yy] 

|- [Licenses] : License group 
|- [Drivers] : Driver group 
|    |- [board] : Drivers related to the evaluation board 
|    |    |- [S5U1C31xxxTx] 
|    |    |    |- [ARM] 
|    |    |    |- [IAR] 
|    |    |    |- board.c/.h : Evaluation board setting program 
|    |    |    |- settings.h : Definition file for setting the function of the evaluation board 
|    |    |    |- … 
|    |- [CMSIS] : CMSIS driver 
|    |    |- [Device] 
|    |    |    |- [S1C31xxx] 
|    |    |        |- [Include] 
|    |    |        |    |-S1C31xxx.h : CMSIS peripheral circuit access layer header file 
|    |    |        |    |- … 
|    |    |        |- [Source] 
|    |    |            |- [ARM] 
|    |    |            |- [IAR] 
|    |    |            |    |- startup_S1C31xxx.s : CMSIS startup program 
|    |    |            |- system_S1C31xxx.c : CMSIS peripheral circuit access layer program 
|    |    |- [Driver] 
|    |    |    |- [Include] 
|    |    |    |    |- Driver_EEPROM.h : CMSIS EEPROM emulation library driver definition 
|    |    |    |    |- Driver_Flash.h : CMSIS self-programming library driver definition 
|    |    |    |    |- … 
|    |    |    |- [Source] 
|    |    |        |- Driver_EEPROM.c 
|    |    |- [SVD] 
|    |- [sePeripheralLibrary] : Peripheral circuit library 
|        |- se_clg.c/.h 
|        |- se_i2c.c/.h 
|        |- … 
|- [Middlewares] : Middleware group 
|    |- [seEepromLibrary] : EEPROM emulation library 
|    |- [seFlashLibrary] : Self-programming library driver definition 
|    |- … 
|- [Projects] : Sample software group 
|    |- [Applications] : Various application software 
|    |    |- [BOOTLOADER] : Sample software for boot loader 
|    |    |- [EEPROM] : Sample software for EEPROM emulation library 
|    |    |- [FLASH] : Sample software for self-programming library 
|    |    |- [IEC60730SELF] : Sample software for self-testing 
|    |    |- … 
|    |- [Demonstration] : Various demonstration software 
|    |- [Examples] : Peripheral circuit sample software 
|        |- [CLG] : Each peripheral circuit function 
|        |    |- [ARM] : Project for MDK-ARM 
|        |    |- [IAR] : Project for IAR EWARM 
|        |    |- main.c 
|        |- [I2C] 
|        |- [PPORT] 
|        |- … 
|        |- [WORKSPACE] : A workspace that collects project of each peripheral circuit function 
|- [Tools] : Tools used by the sample software 
README_e.txt 
README_j.txt 
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2.2 Sample Software configuration 

The sample software (project) included in the S1C31xxx peripheral circuit sample software package uses various 
drivers included in the "Drivers" folder. The software layer of the sample software is shown in Figure 2.2.1. 

 

 
Figure 2.2.1 Software layer of sample software 

 

In addition, as shown in Figure 2.2.2, the sample software is started from the CMSIS startup program 

(startup_S1C31xxx.s), and the system initialization process is executed at startup. 

 

 
Figure 2.2.2 Sample software startup sequence 

  

startup_S1C31xxx.s 

 

system_S1C31xxx.c 

 

board.c 

 

System initialization process 
・ Operating frequency setting 
・ Evaluation board setting 
・ Sys Tick setting 
etc 

BoardInit() 
 

SystemInit() 
 

MCU Hardware 

Drivers¥CMSIS 
(startup_S1C31xxx.s, system_S1C31xxx.c, S1C31xxx.h, etc…) 

 

Drivers¥board 
(board.c, settings.h, etc…) 

Drivers¥sePeripheralLibrary 
(se_clg.c/.h, se_i2c.c/.h, se_pport.c/.h, etc…) 

Middlewares 
(seFlashLibrary etc…) 

Projects 
 (Examples, Applications, etc…) 
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2.3 Evaluation board settings 

The settings.h file contained in the “Drivers ¥ board” folder defines the function settings of the evaluation board. 
Table 2.3.1 shows the setting constants and settings in the settings.h file. These setting constants are commented 
out and undefined by default. If necessary, uncomment it. 
 

Table 2.3.1 S1C31 Family Evaluation Board Definition  

Configuration Feature Defined Un-defined 
UART_PRINTF The standard library printf function 

outputs to the UART console. 
Additional hardware is required. 
For Keil IDE, this configuration 
feature should be defined. 

The semihosting library printf function 
outputs to the IAR IDE terminal 
window. 

EXECUTE_ON_OSC3 The CPU switches to the clock that 
optionally can be run from crystal 
or internal trimmable oscillator in 
the BoardInit function. 

The CPU uses the default clock. 

OSC3_AUTOTRIMMING_ON 
IOSC_AUTOTRIMMING_ON 

OSC3 or IOSC trimming is 
performed in the BoardInit() 
function to achieve higher CPU 
clock accuracy. 

OSC3 or IOSC trimming is not 
performed. This results in a shorter 
boot time. 

OSC3_SRC_XTAL Crystal is source of OSC3 Internal RC oscillator is source of 
OSC3 

CACHE_ENABLED The cache is enabled for the Flash 
targets. No importance for Debug 
targets, 

The cache is not enabled for the 
Flash targets. 

TICKLESS_ENABLED SYSTICK interrupt is disabled. SYSTICK interrupt is used to keep 
track of the elapsed CPU time since 
the last boot. 

BOOT_LOADER Executing code is a boot loader. Executing code is an application. 
QSPI_MODE_SINGLE QSPI SINGLE mode is selected. QSPI DUAL or QUAD modes are 

selected. 
SPIA_DMA Use DMA for SPIA_MASTER and 

SPIA_SLAVE projects. 
Do not use DMA for SPIA_MASTER 
and SPIA_SLAVE projects. 

 

Notes: 

• The definition of “Configuration Feature” is different for each model.  
• To use the UART console for input/output, un-comment UART_PRINTF in the settings.h file. 
• In cases where the CPU deep sleep function is used, un-comment TICKLESS_ENABLED in the settings.h 

file. 
 
  



3          Peripheral circuit sample software execution 
 

S1C31 Family Peripheral Circuit Seiko Epson Corporation 5 
Sample Software Manual (Rev.1.1) 

3 Peripheral circuit sample software execution 
This section describes how to execute the peripheral circuit sample software. 
 
3.1 Advance preparation 

3.1.1 Software download 

Follow the steps below to download and install the software. 

(1) Download the integrated development environment 
Download the integrated development environment (IAR EWARM or MDK-ARM (µVision)). 
After downloading, follow the installer to install. 
 

(2) Download the S1C31 setup tool package 
Download the S1C31 setup tool package (.exe) from Seiko Epson microcontroller website. 
Please download from the following. 

Seiko Epson microcontroller website > EPSON Web Sites > Semiconductors > 
Microcontrollers > Arm® > Software Development Tool 

After downloading, follow the installer to install the flash loader and configuration file 
suitable for your integrated development environment. 
 

(3) Download the S1C31xxx peripheral circuit sample software package 
Download the S1C31xxx Peripheral circuit sample software package (.zip) from Seiko 
Epson microcontroller website. Please download from the following. 

Seiko Epson microcontroller website > EPSON Web Sites > Semiconductors > 
Microcontrollers > Arm® > Application Note / Sample Program 

 
3.1.2 Hardware Connections 

Use the following to execute and debug the peripheral circuit sample software. 

• S5U1C31xxxTx evaluation board 
• Debug probes (IAR Systems I-jet or SEGGER J-Link) 

About details of the hardware connection, refer to the “S5U1C31xxxTx Manual”. 

 
3.1.3 Connection with USB adapter for UART  

The peripheral circuit sample program that uses UART uses a USB adapter for UART. By connecting the 
evaluation boat to the PC using the USB adapter for UART, UART communication with the PC becomes 
possible. Figure 3.1.3.1 show the connection for an USB Adapter for UART to the evaluation board. About the 
connection with the evaluation board, refer to "S5U1C31xxxTx Manual". 

To perform UART communication, it is necessary to build the sample program with the definition of 
UART_PRINTF in the settings.h file enabled (see Section 2.3). In addition, it is necessary to start the serial 
communication terminal software on the PC and set the serial port. Table 3.1.3.1 shows the serial port setting 
values. 
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Figure 3.1.3.1 USB Adapter for UART Wiring to Evaluation Board 

 

Table 3.1.3.1 Serial Port Settings for Terminal Software 

Parameter Setting Value 

Baud rate 115200 bps 

Data 8 bits 

Stop bits 1 bits 

Parity None 

 

Notes: USB adapter for UART used in Figure 3.1.3.1 is a commercial product, not provided by Seiko Epson. 
Please purchase as necessary. 

  

Evaluation Board 

TXD UART/Ch.0/USIN 
RXD 

GND 
UART/Ch.0/USOUT 
GND 

USB to PC 

USB adapter for UART 
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3.2 Execution procedure by IAR EWARM 

3.2.1 Start IAR EWARM 

Start IAR EWARM. About details on the version of IAR EWARM used to evaluate the peripheral circuit sample 
software, refer to “README_j.txt” in the S1C31xxx peripheral circuit sample software package. 

 

3.2.2 Workspace Open 

The S1C31xxx Peripheral Circuit Sample Software Package provides projects for each peripheral circuit function 
as peripheral circuit sample software. It provides a workspace that collects projects for each peripheral circuit 
function. 

To open the workspace, click [File] > [Open Workspace] on the IAR EWARM menu, move to the 
“Projects¥Examples¥WORKSPACE¥IAR” folder and select the “Examples.eww” file. (Figure 3.2.2.1) 

 

 
Figure 3.2.2.1 Workspace Open 
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3.2.3 Active Project Selecting 

To build the project, right-click the project to be built and executed in [Workspace] window on IAR EWARM and 
select the [Set as Active] in right-clicked menu. By using the drop-down list at the top of the [Workspace] 
window, the active project and build configuration can be selected at the same time (Figure 3.2.3.1). 

 

 
Figure 3.2.3.1 Active Project Setting 

  



3          Peripheral circuit sample software execution 
 

S1C31 Family Peripheral Circuit Seiko Epson Corporation 9 
Sample Software Manual (Rev.1.1) 

3.2.4 Debug Probe Setting 

When connecting a debug probe to the evaluation board for debugging, it is necessary to set the driver according 
to the type of debug probe used. 

To select the debug probe driver, follow the procedure below. (Figure 3.2.4.1) 

(1)  Select the [Project] > [Option] in the IAR EWARM menu. 

(2)  Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog. 

(3)  Select the [Setting] tab, and then select the debug probe in the [Driver] drop-down list as shown below. 

- When using the I-jet , select the “I-jet/JTAGjet”. 

- When using the J-Link, select the “J-Link/J-Trace”. 

- When using the DAPLink, select the “CMSIS-DAP”. 

 

 
Figure 3.2.4.1 Debug Probe Setting 
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3.2.5 Flash Loader Setting 

Set up a flash loader to download the internal Flash memory for active projects. To set the flash loader, follow the 
procedure below. (Figure 3.2.5.1). 

(1)  Select the [Project] > [Option] in the IAR EWARM menu. 

(2)  Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog. 

(3)  Select the [Download] tab. 

(4)  Enable the [Use flash loader(s)] checkbox. 

(5)  Enable the [Override default .board file] checkbox. 

(6)  Click the [...] button and select “S1C31xxx_int.board” as a board file. 

 

 
Figure 3.2.5.1 Flash Loader Setting  
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3.2.6 Project Build 

To build an active project, select one of the build commands [Make] or [Rebuild All] from the [Project] in the 
IAR EWARM menu (Figure 3.2.6.1). 

Also, the batch build option to build the projects of all peripheral circuit function at once is available. To use the 
batch build option, select the [Project] > [Batch build…] > “all_DebugFlash” in the IAR EWARM menu.  

 

 
Figure 3.2.6.1 Build Commands 

  

Build the project 

Build the projects of 

all peripheral circuit 

function at once is 

available. 
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3.2.7 Project Download and Debug 

Following a successful build, download the program image of the active project to MCU on the evaluation board. 
To download the program image, select the [Project] > [Download and Debug] in IAR EWARM menu (Figure 
3.2.7.1).  

The project image is loaded in the internal flash memory and debugging is started. 

  

 
Figure 3.2.7.1 Download and Debug 
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3.3 Execution procedure by KEIL MDK-ARM (µVision)  

3.3.1 Start MDK-ARM (µVision) 

Start MDK-ARM (µVision). About details on the version of MDK-ARM used to evaluate the peripheral circuit 
sample software, refer to “README_j.txt” in the S1C31xxx peripheral circuit sample software package. 

 
3.3.2 Workspace Open 

The S1C31xxx Peripheral Circuit Sample Software Package provides projects for each peripheral circuit function 
as peripheral circuit sample software. It provides a workspace that collects projects for each peripheral circuit 
function. 

To open the workspace, click [Project] > [Open Project…] on the uVision menu, move to the 
“Projects¥Examples¥WORKSPACE¥ARM” folder and select the “Examples.uvmpw” file. (Figure 3.3.2.1) 

 

 
Figure 3.3.2.1 Workspace Open 
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3.3.3 Active Project Selecting 

To build the project, select a project to be built and executed. Right-click the target project in [Project] window 
on µVision and select the [Set as Active Project] in right-clicked menu . Next, select the build configuration listed 
in the drop-down list on the tool bar of µVision (Figure 3.3.3.1). 

 

 
Figure 3.3.3.1 Active Project Setting 
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3.3.4 Debug Probe Setting 

When connecting a debug probe to the evaluation board for debugging, it is necessary to set the driver according 
to the type of debug probe used. 

To select the debug probe driver, follow the procedure below. (Figure 3.3.4.1) 

(1)  Select the [Project] > [Options for {Project Name} - Target ‘DebugFlash’] in the µVision menu. 

(2)  Switch the [Debug] tab in the [Options for Target ‘DebugFlash’] dialog. 

(3)  Select the debug probe from the drop-down list at the right side of [Use:] checkbox. 

- When using the J-Link, select the “J-Link / J-Trace Cortex”. 

- When using the DAPLink, select the “CMSIS-DAP Debugger”. 

(4)  Click the [Settings] button at the right side of the above drop-down list. 

(5)  Select the [SW] from the [Port:] drop-down list in the [{Debug Probe Name} Target Driver Setup] dialog 
box. 

(6)  Click the all [OK] button to close all dialogs. 

Notes:  

• This setting needs to be done with the debug probe connected to the PC. 

• "ULINK2 / ME Cortex Debugger" is set as the default debug probe for each peripheral circuit function 
project. 

 
Figure 3.3.4.1 Debug Probe Selecting  
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3.3.5 Flash Loader Setting 

Set up a flash loader to download the internal Flash memory for active projects. To set the flash loader, follow the 
procedure below. (Figure 3.3.5.1) 

(1) Select the [Project] > [Options for {Project Name} - Target ‘DebugFlash’] in the µVision menu. 

(2) Select the [Utilities] tab in the [Options for Target ‘DebugFlash’] dialog, and click the [Settings] button in 
the [Configure Flash Menu Command]. 

(3) Click the [Add] button in the [{Debug Probe Name} Target Driver Setup] dialog and select the flash loader 
“S1C31xxxint yyykB Flash” that matches the target MCU from [Add Flash Programming Algorithm].  
If a flash loader other than the above is registered in [Programming Algorithm], click the [Remove] button 
to remove it. 

(4) Enable the checkboxes, [Erase Sectors], [Program] and [Verify], in the [Download Function]. Set the RAM 
area of the target MCU in the textboxes of [Start] and [Size] in the [RAM for Algorithm]. 

 

 
Figure 3.3.5.1 Flash Loader Setting 
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3.3.6 Project Build 

To build an active project, select one of the build commands [Build] and [Rebuild] from the [Project] in the 
µVision menu (Figure 3.3.6.1). 

Also, the batch build option to build the projects of all peripheral circuit function at once is available. To use the 
batch build option, select the [Project] > [Batch Build] in the µVision menu.  

 

 
Figure 3.3.6.1 Build Commands 

  

Build the project 

Build the projects of 

all peripheral circuit 

function at once is 

available. 
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3.3.7 Project Download and Debug 

Following a successful build, download the program image of the active project to MCU on the evaluation board. 
To download the program image, select the [Flash] > [Download] in µVision menu (Figure 3.3.7.1).  

To start debugging, select the [Debug] > [Start/Stop Debug Session] in µVision menu (Figure 3.3.7.2). 

 

 
Figure 3.3.7.1 Download 

 

 
Figure 3.3.7.2 Debug 
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4 Peripheral circuit sample software 
Each peripheral circuit sample software shows how to use the peripheral circuit functions. About an overview of 
each peripheral circuit sample software, refer to main.c included in the target project. About the target peripheral 
circuits, refer to "S1C31xxx Technical Manual". 
Table 4.1 shows a list of code sizes when the peripheral circuit sample software is built with IAR EWARM or 
MDK-ARM. 
 

Table 4.1 Code size of each peripheral circuit sample software 

Example Project Name IAR EWARM 
(Code size is 16 KB or less.) 

MDK-ARM 
(Code size is 32 KB or less.) 

ADC12A 
�� 
�� 
CLG 
�� 
�� 
DMAC 
�� 
�� 
I2CLCD32BI2C 
�� 
�� 
LCD32B 
�� 
�� 
MCD_LPM012M134B - - 
MDC_LPM012M134B_SERFLASH - - 
MDC_LS012B7DH02 - - 
PPORT 
�� 
�� 
QSPI 
�� 
�� 
QSPI_DMA 
�� 
�� 
QSPI_MASTER 
�� 
�� 
QSPI_SLAVE 
�� 
�� 
REMCn 
�� 
�� 
RFC 
�� 
�� 
RTCA 
�� 
�� 
SNDA 
�� 
�� 
SPI_MASTER 
�� 
�� 
SPI_SLAVE 
�� 
�� 
SVDn 
�� 
�� 
T16 
�� 
�� 
T16B 
�� 
�� 
TSRVR - - 
UARTn 
�� 
�� 
USB_CDC 
�� 
�� 
USB_HID - - 
USB_MSC - - 
WDT2 
�� 
�� 

 
Note: Depending on the version of the IDE (Integrated development environment) or the build configuration of 
the IDE, the code size may exceed the size. 
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Revision History 
 Attachment-1 

Rev. No. Date Page Category Contents 
Rev.1.0 1/15/2021 All New New create 

Rev.1.1 4/7/2022 9, 15 Add Added ‘DAPLink’ to the debug probe selection in section 3.2.4 
and 3.3.4. 
Added description of RAM area setting in section 3.3.5 

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

 



 

 International Sales Operations 

 

 
America 
Epson America, Inc. 
 
Headquarter: 
3131 Katella Ave. 
Los Alamitos, CA 90720, USA 
Phone: +1-800-463-7766 
 
San Jose Office: 
2860 Zanker Road Suite 204 
San Jose, CA 95134, USA 
Phone: +1-800-463-7766 
 
 
Europe 
Epson Europe Electronics GmbH 
Riesstrasse 15, 80992 Munich, 
Germany  
Phone: +49-89-14005-0 FAX: +49-89-14005-110 
 
 

 
Asia 
Epson (China) Co., Ltd. 
4th Floor, Tower 1 of China Central Place, 81 Jianguo Road, Chaoyang 
District, Beijing 100025 China  
Phone: +86-10-8522-1199 FAX: +86-10-8522-1120 
 
Shanghai Branch 
Room 601-603, Building A One East, No.325 East Longhua Road, 
Shanghai 200023, China 
Phone: +86-21-5330-4888     FAX: +86-21-5423-4677 
 
Shenzhen Branch 
Room 804-805, 8 Floor, Tower 2, Ali Center,No.3331 
Keyuan South RD(Shenzhen bay), Nanshan District, Shenzhen 
518054, China 
Phone: +86-755-3299-0588 FAX: +86-755-3299-0560 
 
 
 
Epson Taiwan Technology & Trading Ltd. 
15F, No.100, Songren Rd, Sinyi Dist, Taipei City 110. Taiwan 
Phone: +886-2-8786-6688  
 
 
Epson Singapore Pte., Ltd. 
438B Alexandra Road,  
Block B Alexandra TechnoPark, #04-01/04, Singapore 119968 
Phone: +65-6586-5500 FAX: +65-6271-7066 
 
 
Epson Korea Co.,Ltd 
10F Posco Tower Yeoksam, Teheranro 134 Gangnam-gu,  
Seoul, 06235, Korea 
Phone: +82-2-3420-6695 
 
 
 
Seiko Epson Corp. 
Sales & Marketing Division 
 
MD Sales & Marketing Department 
JR Shinjuku Miraina Tower, 4-1-6 Shinjuku,  
Shinjuku-ku, Tokyo 160-8801, Japan 
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