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1. Introduction 

CFG is an interactive Windows® configuration tool for determining S1D13513 register 

values based on a user defined configuration. The configuration information can be used 

to directly alter the operating characteristics of S1D13513 utilities, such as 13513PLAY, 

or any program built with the Application Programming Interface (API) or Hardware 

Abstraction Layer (HAL) libraries. Alternately, the configuration information can be 

saved in a variety of text file formats for use in other applications. 

Note 

This program is a utility program designed to assist with testing and evaluating the 

S1D13513 display controller. It is not a display driver for any operating system. 

This user manual is updated as appropriate. Please check for the latest revision of this 

document at vdc.epson.com before beginning any development. 

We appreciate your comments on our documentation. Please contact us via email at  

vdc-documentation@ea.epson.com. 

1.1. 13513 CFG Supported Evaluation Platforms 

13513 CFG runs on a PC system running Windows XP/Vista and can modify Win32 

executable files. 

The latest version of the 13513 CFG executable is available on the internet at 

vdc.epson.com. 
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2. Installation 

To install the 13513 CFG utility, create a folder (e.g. C:\S1D13513\) and copy the 

following files into the folder. 

• cfg.exe 

• panels.xml 

• cameras.xml 

Panels.xml contains predefined settings for a number of panels. Cameras.xml contains 

predefined settings for a number of camera modules. Both files must reside in the same 

directory as the 13513 CFG utility. 
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3. Usage 

To start 13513 CFG from the Windows GUI, navigate to the directory CFG was installed 

in and double-click on the program icon. To start 13513 CFG from a Windows command 

line, start a command prompt window, change to the folder 13513 CFG was installed to, 

and type the command cfg. 

The basic procedure for using 13513 CFG is: 

1. Start the CFG utility as described above. 

2. Open an existing file (i.e. 13513 play.exe) to serve as a starting reference point. 

 (this step is optional) 

3. Modify the configuration information from the Features tab. 

4. Save the new configuration. 

Configuration information can directly modify any executable built with the 

Application Programming Interface (API) or Hardware Abstraction Layer (HAL) 

libraries, or it can be saved as an ASCII text file. Several ASCII text file formats are 

supported. Most are formatted C header files used to build display drivers or 

standalone applications. 
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4. 13513 CFG Configuration Tabs 

13513 CFG displays two tabs which can be selected at the top of the main window. The 

following sections describe the purpose and use of each tab. 

4.1. Features Tab 

 

The Features Tab allows a specific S1D13513 configuration to be defined. All features 

are presented in a tree-control pane. The configuration is changed by selecting the desired 

setting for each feature. If the panels.xml and cameras.xml files are present in the same 

folder as the 13513 CFG utility, a number of predefined panel and predefined camera 

configurations are available. 

For detailed information about each feature, hover the cursor over the feature name and a 

tooltip will be shown with expanded information (i.e. corresponding registers and 

bitfields). The Diagnostics pane displays a warning if any features have been set with 

invalid values. 
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4.2. Registers Tab 

 

The Registers Tab allows viewing and editing of the S1D13513 register values. The 

registers are listed in the order in which they will be initialized by an application. 

Scroll up and down the list to view the register values which are determined from the 

configuration settings on the Features Tab. Hovering over a register displays the 

functionality of the bitfields in that register. 

Register settings may be changed by double-clicking on the register in the listing. Manual 

changes to the registers are not checked for errors, so caution is warranted when directly 

editing these values. For detailed descriptions of each register, refer to the S1D13513 

Hardware Functional Specification, document number X78B-A-001-xx. 

Note 

Register values that are manually entered on the Register Tab may be changed by 

13513 CFG if further configuration changes are made on Features Tab. In this case, 

the user is notified with a message in the Diagnostics pane when the user returns to 

the Register Tab. 
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5. 13513 CFG Menus 

The following sections describe some of the options in the File and Help menus. 

5.1. Open… 

From the File menu, select “Open…” to display the Open File Dialog Box. 

 

The Open option allows the 13513 CFG utility to read the configuration information from 

programs based on the API or HAL libraries. When 13513 CFG opens a file, it scans the 

file for an identification string, and if found reads the configuration information. This 

feature may be used to quickly arrive at a starting point for register configuration. 

The 13513 CFG utility supports a variety of executable file formats. Select the file 

type(s) 13513 CFG should display in the “Files of type” drop-down list. Then select the  

“File name” from the list and click the Open button. 

Note 

13513 CFG is designed to work with utilities programmed using a given version of 

the API/HAL. If the configuration structure contained in the executable file differs 

from the version 13513 CFG expects, the Open command will fail and an error 

message is displayed. This may happen if the version of 13513 CFG is substantially 

older, or newer, than the file being opened. 
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5.2. Save 

From the File menu, select “Save” to perform a fast save of configuration information to 

the file that was previously opened with the Open menu option. The file that was opened 

will be updated with the new configuration information. 

Note 

This option is only available once a file has been opened. 

5.3. Save As… 

From the File menu, select “Save As…” to display the Save As dialog. 

 

“Save As” is similar to Save, except the dialog permits renaming the file before it is 

saved. Using this technique, a user can configure a number of files differing only in 

configuration information and name. 

Note 

When “Save As” is selected, an exact duplicate of the file as opened by the “Open” 

option is created containing the new configuration information. 



13513 CFG Menus 
 

12 Seiko Epson Corporation S1D13513 CFG Configuration Utility 
  (Rev.1.1) 

5.4. Configure Multiple 

After determining a desirable configuration, the Configure Multiple option allows the 

information to be saved into one or more executable files built with the API/HAL 

libraries. 

From the File menu, select “Configure Multiple” to display the Configure Multiple 

Dialog box. 

 

The left pane lists files available for configuration and the right pane lists files that have 

been selected for configuration. Files can be selected by clicking the “Add” or “Add All” 

buttons or by double-clicking any file in the left pane. 
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5.5. Export 

After determining a desirable configuration, “Export” allows the user to save the register 

information as a variety of ASCII text file formats  

 

The following is a list of the currently supported output formats: 

• C header file tailored for use in writing HAL library applications. 

• C header file which lists each register and the value it should be set to. 

(additional configuration information and hints such as clock frequencies and 

display resolutions are suppressed) 

• C header file tailored for use in developing Windows CE display drivers. 

• C header file intended for use in developing display drivers for operating systems 

such as Linux, QNX, and VxWorks. 

• Comma delimited text file containing the configuration information in CSV 

format. 

• Text file that can be used as a reference guide to the S1D13513 registers. 

• C source file containing configuration information for S1D13513 API support. 

After selecting the file format, click the “Export As…” button to display the file dialog 

box which allows the user to enter a filename before saving. 



13513 CFG Menus 
 

14 Seiko Epson Corporation S1D13513 CFG Configuration Utility 
  (Rev.1.1) 

5.6. Save and Run 

After determining the desired configuration, “Save and Run” allows the user to save the 

configuration information to an executable file that was opened with the Open menu 

option and then run that file. 

Note 

This option is only available once a file has been opened. 

5.7. Command Line 

The “Command Line” option is used in conjunction with “Save and Run” option. When 

the “Command Line” option is selected, the Command Line Box is open and allows the 

user to input the arguments for running the executable file when the “Save and Run” 

command is used. 

Note 

This option is only available once a file has been opened. 

5.8. Enable Debugging 

This menu item is Reserved for internal use only. 

5.9. Enable Tooltips 

Tooltips provide useful information about many of the items in the Features pane. Placing 

the mouse pointer over any feature will display additional information below the 13513 

CFG window. 

To enable/disable tooltips check/uncheck the ‘Enable Tooltips’ option in the Help menu. 

Note 

Tooltips are enabled by default. 

5.10. Tooltip Delay 

Specifies the time before tooltips fade. 
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5.11. ERD on the Web 

This “Help” menu item is a hotlink to the Epson Reasearch and Development website. 

Selecting “Help”, then “ERD on the Web” starts the default web browser and opens the 

Epson Research and Development home page. 

The latest software, drivers, and documentation for the S1D13513 are available on this 

website. 

5.12. Update Common Controls 

13513 CFG uses some of the latest common control DLLs. On systems using earlier 

versions of the common controls, certain controls may not appear correctly. This option 

updates the Common Controls required for proper operation of 13513 CFG. 

5.13. About 13513 CFG 

Selecting the “About 13513 CFG” option from the “Help” menu displays the About 

13513 CFG dialog box which contains version information and the copyright notice for 

13513 CFG. 
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6. Comments 

• Options in the File Menu and Save/Run! Menu may be “greyed out” if they are not 

selectable in the current state of the 13513 CFG utility. For example, the “Save”, 

“Save As”, and “Save and Run” options from the File menu, and the Save/Run! 

Menu are “greyed out” if no file has been opened in 13513 CFG. 

• 13513 CFG allows the user to manually alter the registers values. The manual 

changes may violate memory and LCD timing as specified in the S1D13513 

Hardware Functional Specification, document number X78B-A-001-xx. If this is 

done, unpredictable results may occur. Epson Research and Development Inc. does 

not assume liability for any damage done to the display device as a result of 

configuration errors. 
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7. Change Record 

X78B-B-002-01 Revision 1.1 - Issued: March 29, 2018  

• Updated address/contact page 

• Updated Epson web page and email address 

• Minor formatting changes 

X78B-B-002-01 Revision 1.0 - Issued: December 12, 2007  

• released as Revision 1.0 

X78B-B-002-00 Revision 0.01 - Issued: November 08, 2007  

• initial draft of the document 
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8. Sales and Technical Support 
 

 

 

 

 

For Sales and Technical Support, contact the Epson representative for your region. 

https://global.epson.com/products_and_drivers/semicon/information/support.html 

For more information on Epson Display Controllers, visit the Epson Global website. 

https://global.epson.com/products_and_drivers/semicon/products/display_controllers/ 

https://global.epson.com/products_and_drivers/semicon/information/support.html
https://global.epson.com/products_and_drivers/semicon/products/display_controllers/
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